logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Mike  
#1 Posted : Tuesday, September 2, 2014 7:51:21 PM(UTC)
Mike


Rank: Administration

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 5/30/2012(UTC)
Posts: 477
Location: Raleigh, NC

Thanks: 52 times
Was thanked: 75 time(s) in 61 post(s)
UserPostedImage

The "Auto Respond to Message" extension will auto respond to messages from Access clients when a Host is not connected to the session. The message is customizable.

This extension is now available in the Online Extensions Library.

Read Me Notes: There are a few configurations that can be made to customize this Extension.

1. In the SessionEventTrigger.xml file, you can specify the From address for the messages. If not included, the field will be the default Mail from value.
In the file, find the SmtpTriggerAction area and add:
To=""
With a value in the "" field.
A correct setting should look like:
<TriggerAction xsi:type="SmtpTriggerAction" To="email@address.com" Subject="AutoResponse has executed" Body="{Event.Data}"/>

2. Also in the SessionEventTrigger, the ScreenConnect server's web service port may need to be configured if it is different than the default (8040). You can
change it in the HttpTriggerAction section by changing the port in the URI to whatever your server is using.

3. In the Resource file (Web.en-US.resx):
You can configure the username (AutoResponse.HostName) from which the auto response is sent
And you can configure the message itself (AutoResponse.Message).


Disclaimer: This extension was written by our support team (and in some cases in conjunction with our forum community) in response to customer requests. Extensions are meant to be quick workarounds or immediate solutions to problems. Extensions are not supported under our normal terms of service, as these extensions are outside typical Q/A or development guidelines. Questions for extensions should be addressed in its respective forum post. Suggestions for improvements (enhancements or defects) should also be queued in the post for consideration.
ScreenConnect Team
jburroughs  
#2 Posted : Monday, December 22, 2014 9:42:20 PM(UTC)
jburroughs


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 7/30/2014(UTC)
Posts: 17

Was thanked: 3 time(s) in 2 post(s)
Hi,

I think this is a pretty neat extension, but I am not able to get it working. I am running SC version 5.0.7909.5428.
The result I'm getting is that I can send a chat message as the guest, and I receive the email alert that Auto-Response has executed, but:

1. The guest does not get any IM in response.
2. The body of the email notification contains no event data.

I have tried using the default URI and the default resource settings, and I have tried configuring them, but it doesn't seem to change the results I'm getting. Any ideas on where I'm going wrong?
Scott  
#3 Posted : Tuesday, December 23, 2014 4:31:36 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
Try creating a Trigger to directly execute the Extension method. It should look like:

UserPostedImage

Be sure to replace the [YOUR_URI_HERE] with your ScreenConnect server's URI and port. If you're server was at example.com, it would be:

Code:
http://example.com/App_Extensions/....
ScreenConnect Team
jburroughs  
#4 Posted : Thursday, December 25, 2014 2:35:46 PM(UTC)
jburroughs


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 7/30/2014(UTC)
Posts: 17

Was thanked: 3 time(s) in 2 post(s)
Thanks for the suggestion!

I tried creating the rules manually per your example, but it didn't seem to help. Here is a screenshot of what I have configured:

Auto Respond Config

I also tried cloning the rules in the Event Triggers file in this extension's folder. Do I need to restart the SC services for changes to triggers to apply?
Scott  
#5 Posted : Friday, December 26, 2014 1:31:20 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
If you're using ssl, you can't use localhost for the URI. You should try to specify the URL completely, ie https://my.domain.com/App_Extensions/...
ScreenConnect Team
jburroughs  
#6 Posted : Friday, May 8, 2015 7:12:25 PM(UTC)
jburroughs


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 7/30/2014(UTC)
Posts: 17

Was thanked: 3 time(s) in 2 post(s)
Sorry for the late post, this was a lower priority item and got moved to the back burner for a while there.

Thanks for all your help!
I was able to get this working on my SC instance (now on the latest stable release) by editing the extension files themselves to configure the trigger/actions. I set the URL to use HTTPS on the correct port and added in the server FQDN instead of "localhost". I also realized that the server was sending this HTTPS request to itself, and my server was not in the allowed IP range specified to access this server in the web.config. Also had an issue with the server connecting to itself since the public IP is just a NATed private, but adding a hosts file entry for the FQND to resolve to the local IP fixed that.

This extension is working like a charm now!
I would really love to expand on this however to also send a chat message to the guest to notify them each time a host connects and disconnects. It would also be neat if we could pull the name of the connected user into this notification. Is this something I could set up myself? I imagine I could just duplicate the extension folder and specify new triggers/actions in the extension files contained therein, however I am not sure if this is the right approach or how exactly I should construct the trigger. Would you be able to point me in the right direction here?

Edited by user Friday, May 8, 2015 7:31:53 PM(UTC)  | Reason: formatting and typos

Mike  
#7 Posted : Thursday, June 4, 2015 1:38:32 PM(UTC)
Mike


Rank: Administration

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 5/30/2012(UTC)
Posts: 477
Location: Raleigh, NC

Thanks: 52 times
Was thanked: 75 time(s) in 61 post(s)
Customer feature request:

"I have the auto-response extension enabled so that when a user attempts to message us and no one is viewing their session, they get an auto-response informing them of that (and in addition the “Notify when guest sends message to unconnected session” trigger sends us the message). This is great when no one is actively monitoring a guest’s remote session, but when we are trying to have a back-and-forth conversation with a guest without being actively connected to their session, they keep getting the auto-response every time they send a reply. Is there any way to fix this, or temporarily disable the auto-response for a particular guest when a back-and-forth conversation is going on (without us being connected to their session)?"
ScreenConnect Team
Kuffy  
#8 Posted : Friday, July 3, 2015 8:32:24 AM(UTC)
Kuffy


Rank: Advanced Member

Joined: 6/24/2015(UTC)
Posts: 36
United Kingdom

Thanks: 1 times
I seem to get two emails.

"[SC] Your guest to session '123456' sent you a message" with the actual message. Super!

and another

A blank message with the subject "AutoResponse has executed". Not super!

I haven't set up a trigger for that. How can that be suppressed?

Cheers.





Scott  
#9 Posted : Monday, July 13, 2015 2:41:31 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
The extension contains its own SessionEventTrigger.xml file with that second 'AutoResponse has executed' SMTP action. You can just delete that file if you would like. Easiest way to do this is to Clone the extension (you may need to install the Extension Developer extension to do this). After cloning, Edit the clone and Delete SessionEventTrigger.xml file AND the component reference in Manifest.xml, which looks like:

Code:

<SessionEventTriggerDefinition SourceFile="SessionEventTrigger.xml" />
ScreenConnect Team
zlittle  
#10 Posted : Friday, August 7, 2015 6:34:03 PM(UTC)
zlittle


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/26/2015(UTC)
Posts: 3
United States
Location: Maryland

Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: Mike Go to Quoted Post
Customer feature request:

"I have the auto-response extension enabled so that when a user attempts to message us and no one is viewing their session, they get an auto-response informing them of that (and in addition the “Notify when guest sends message to unconnected session” trigger sends us the message). This is great when no one is actively monitoring a guest’s remote session, but when we are trying to have a back-and-forth conversation with a guest without being actively connected to their session, they keep getting the auto-response every time they send a reply. Is there any way to fix this, or temporarily disable the auto-response for a particular guest when a back-and-forth conversation is going on (without us being connected to their session)?"



Has any development related to this post been done? Sometimes it is nice to be able to not connect to the users computer, but still be able to use the chat to walk them through things, or verify that it is ok to connect, or simply follow-up on a recent connection. With the Auto Respond enabled, they receive the Aut-Response & I get an e-mail when chatting via the web-browser (not connected to their session, just viewing that sessions dashboard).
Reid  
#11 Posted : Wednesday, August 19, 2015 2:57:24 PM(UTC)
Reid


Rank: Administration

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 4/22/2010(UTC)
Posts: 475
Location: NC

Was thanked: 17 time(s) in 15 post(s)
I can't say for certain if anything has been done yet but I can say that it is definitely in the queue to be done. I will go ahead and add your +1 to that issue.
ScreenConnect Team
mbressman  
#12 Posted : Saturday, August 29, 2015 12:58:18 AM(UTC)
mbressman


Rank: Newbie

Medals: ScreenConnect Advisor: Focus Group Member

Joined: 5/6/2013(UTC)
Posts: 9
Location: NJ

Any updates on this yet? Thanks.
Reid  
#13 Posted : Wednesday, September 2, 2015 3:19:12 PM(UTC)
Reid


Rank: Administration

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 4/22/2010(UTC)
Posts: 475
Location: NC

Was thanked: 17 time(s) in 15 post(s)
Unfortunately, nothing new to report. It is still in the development queue. Still no ETA, sorry.
ScreenConnect Team
rgreen83  
#14 Posted : Wednesday, September 2, 2015 8:13:39 PM(UTC)
rgreen83


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/16/2015(UTC)
Posts: 68
United States
Location: Missouri

Thanks: 6 times
Was thanked: 3 time(s) in 3 post(s)
Would it be possible to have the emailed message go to the last host connected to the guest? Otherwise the person they go to (currently me) has no way of knowing the context of the message.

Also, the only reason we need this at all is for the times a tech forgets to close the chat window before disconnecting from a session (we hide the tray), so if we could just get an option in app.config to have it automatically close the chat dialog when the host disconnects I wouldn't need this at all. Should I start a new thread in feature requests?
Mike  
#15 Posted : Tuesday, September 8, 2015 1:20:06 PM(UTC)
Mike


Rank: Administration

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 5/30/2012(UTC)
Posts: 477
Location: Raleigh, NC

Thanks: 52 times
Was thanked: 75 time(s) in 61 post(s)
Currently we do not define an email address for hosts, so we would not be able to "route" messages to the proper host.

Close chat on disconnect would need to be listed as a feature request. I've never seen this request in the forum, but it does seem useful. I'm interested to see the support for it, so please post it when you get a chance.
ScreenConnect Team
Pranay  
#16 Posted : Friday, September 18, 2015 6:50:50 PM(UTC)
Pranay


Rank: Newbie

Joined: 9/18/2015(UTC)
Posts: 2
India
Location: Nagpur

I have enable Out of Office extension. But I'm not able to find out the URI which needs to be entered while configuring the trigger. Please help me out with the instruction for how to get this URl.
TT_Vert  
#17 Posted : Thursday, September 24, 2015 6:28:20 PM(UTC)
TT_Vert


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/13/2015(UTC)
Posts: 32

Was thanked: 1 time(s) in 1 post(s)
Is there a way to suppress messages when the user is replying to a message sent from the screen connect web interface message tab?


Thanks
Dave
Mike  
#18 Posted : Friday, September 25, 2015 1:56:12 PM(UTC)
Mike


Rank: Administration

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 5/30/2012(UTC)
Posts: 477
Location: Raleigh, NC

Thanks: 52 times
Was thanked: 75 time(s) in 61 post(s)
Dev team is looking at some fixes for this issue that should be available in rev 3 of the extension. No ETA at this time as they are also trying to address a couple of other issues with the extension and balance out their ScreenConnect workload. We hope to give an update soon
ScreenConnect Team
Scott  
#19 Posted : Wednesday, April 27, 2016 6:32:06 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
Version 1.2 of this Extension has been released and it comes with several changes.


  • The behavior has been redesigned to prevent spamming the Guest with automated messages. It will no longer execute if:

    • It has already executed within the last 10 minutes
    • A message has been sent from the Host page within the last 10 minutes

  • This extension now includes a dynamically defined SessionEventTrigger

    • If you are running ScreenConnect 5.5 or above, you no longer need to define a Trigger in order for the function to execute.
    • If you are running ScreenConnect 5.4 or below, you will need to define your own Trigger


If you are running ScreenConnect 5.4 or below, the following image can be used to help define the Trigger.
Be sure to replace YOUR_SCREENCONNECT_URL with the URL used to access your ScreenConnect server (ie support.mycompany.com)
UserPostedImage

Event Filter:
Code:

Event.EventType = 'SentMessage' AND Connection.ProcessType = 'Guest' AND Session.HostConnectedCount = 0


URL:
Code:

http://YOUR_SCREENCONNECT_URL:8040/App_Extensions/288355c4-f39c-4e34-a31f-23f598575510/Service.ashx/AutoReply/{Session.SessionID}


HTTP Method:
Code:

GET


More information on Triggers can be found here.
ScreenConnect Team
Scott  
#20 Posted : Wednesday, May 4, 2016 2:44:22 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
Version 1.3 has been uploaded and published to the Extension marketplace. It has added an automatic email notification for when the Trigger executes. You can configure the email with the following two settings:
AutoResponse.EmailToAddress
AutoResponse.EmailSubject
ScreenConnect Team
TT_Vert  
#21 Posted : Monday, September 26, 2016 11:05:34 PM(UTC)
TT_Vert


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/13/2015(UTC)
Posts: 32

Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: TT_Vert Go to Quoted Post
Is there a way to suppress messages when the user is replying to a message sent from the screen connect web interface message tab?


Thanks
Dave



Was this resolved? I also am getting two emails after upgrading to version 1.3.
Quote:

"[SC] Your guest to session '123456' sent you a message" with the actual message. Super!

and another

A blank message with the subject "AutoResponse has executed". Not super!

I haven't set up a trigger for that. How can that be suppressed?


Scott  
#22 Posted : Wednesday, October 5, 2016 2:04:05 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
@TT_Vert what other extensions do you have installed? Extensions can also define Session Event Triggers and the easiest way to look is just to enumerate through each folder within App_Extensions in the ScreenConnect installation folder on the server (C:\Program Files (x86)\ScreenConnect by default).
ScreenConnect Team
RobQuartzelec  
#23 Posted : Thursday, October 20, 2016 11:05:05 AM(UTC)
RobQuartzelec


Rank: Guest

Joined: 5/18/2016(UTC)
Posts: 4
United Kingdom
Location: Rugby

Hi,

I'm using this extension and it works well however in this spotlight video:



It shows the message from the user in the body of the e-mail, ours doesn't do that, is there a setting ive missed to enable that?

Thanks.
Scott  
#24 Posted : Thursday, October 20, 2016 1:30:55 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
@RobQuartzelec so after looking at the Extension's code again I noticed that the email isn't configured to include the message within the body. That video, however, has a separate, OOTB Trigger configured to automatically email a notification and the message's contents which is why you saw it there.

With that said, not including the message in the email's body was an oversight which I have just corrected. You can update the extension to version 1.3.2 which has this new feature.
ScreenConnect Team
Joshin_IT  
#25 Posted : Wednesday, November 16, 2016 6:19:53 AM(UTC)
Joshin_IT


Rank: Guest

Joined: 11/16/2016(UTC)
Posts: 3
United States

I just installed this extension and it uses "{0}" (Minus quotes) to reference the GuestMachineName in the default email subject line. I would like to also reference CustomProperty1 if possible. Is there a corresponding code for that?

Thanks

Edited by user Wednesday, November 16, 2016 6:22:01 AM(UTC)  | Reason: Not specified

Scott  
#26 Posted : Wednesday, November 16, 2016 3:53:58 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
@Joshin_IT Right now this isn't available, but I'll add it to my to-do list for the Extension's next update.
ScreenConnect Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.