logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
direwolf  
#1 Posted : Friday, September 1, 2017 12:43:57 PM(UTC)
direwolf


Rank: Newbie

Joined: 2/6/2015(UTC)
Posts: 5
United States

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Site was running great and using LetsEncrypt cert - Time for Renewal
Created New LetsEncrypt Cert from this site: https://www.sslforfree.com (manual/dns verification option)
Went to install new Cert using ScreenConnectConfigurator and had identical error on #4 and #5 (bind server cert and Install PFX)

Error message from ScreenConnectConfigurator:

There was a problem binding the certificate to port 443.
A certificate has already been bound to 0.0.0.0:443
Returning to menu.
Press any key to continue.

How do you unbind/clear the expired/existing SSL cert?

This is running on Windows Server 2012

Thanks in advance!

Edit: LetsEncrypt info

Edited by user Friday, September 1, 2017 8:54:30 PM(UTC)  | Reason: Not specified

direwolf  
#2 Posted : Friday, September 1, 2017 1:35:08 PM(UTC)
direwolf


Rank: Newbie

Joined: 2/6/2015(UTC)
Posts: 5
United States

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
FYI.. doing this broke the site on port 443
I was able to REM out the SSL redirect in WEB.Config

The site is back up 100% on port 80 with a relay on 8041

Webserver running Port 443 is toast until solution found.

EDIT: yes, i had a total panic-freakout-ohmygod moment when the client support portal went totally down. It took a deep breath and 25mins to correct.

Edited by user Friday, September 1, 2017 1:43:34 PM(UTC)  | Reason: Not specified

direwolf  
#3 Posted : Friday, September 1, 2017 2:39:14 PM(UTC)
direwolf


Rank: Newbie

Joined: 2/6/2015(UTC)
Posts: 5
United States

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
OK.. everything is fine. good grief.

To remove old SSL Cert:

Elevated Command Prompt (CMD>run as admin):

netsh http delete sslcert ipport=0.0.0.0:443 (my config/default config)

Then I ran the ScreenConnectConfigurator again #4 (bind SSL)

i did get an error that it couldnt convert to .pem but the new active cert went in place > Reactivated the 443 redirect in WEB.Config > Done.

See you again in 3 months for the next renewal! Aiko Aiko
thanks 1 user thanked direwolf for this useful post.
KellTech on 10/2/2017(UTC)
KellTech  
#4 Posted : Monday, October 2, 2017 6:55:24 PM(UTC)
KellTech


Rank: Newbie

Medals: ScreenConnect Advisor: Focus Group Member

Joined: 3/17/2015(UTC)
Posts: 8
United States

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
Just had the same issue -- thanks for the tip, direwolf. Always nice when someone takes the time to share their solution. I hope that ConnectWise will integrate that ability into future configurators.
thanks 1 user thanked KellTech for this useful post.
direwolf on 10/2/2017(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.