logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
HDClown  
#1 Posted : Tuesday, September 26, 2017 10:43:20 PM(UTC)
HDClown


Rank: Newbie

Joined: 3/25/2017(UTC)
Posts: 19
United States

Was thanked: 2 time(s) in 2 post(s)
ScreenConnect 6.3.13446.6374, Chrome 61 x64, Windows 10 1703. This is a fresh computer load too.

IE11 Issues
URL Launch doesn't work, then it rolls to WindowsInstallerDownload but the download doesn't occur, then it rolls to ClickOnceDirect which does work

I've added the screenconnect site to Trusted Sites, no behavior change

Chrome Issues
URL Launch doesn't work, then it rolls to WindowsInstallerDownload and I see the modal window about running the .EXE for half a second then and then it throws "Server Error in '/' Application.". I have to manually use ClickOnceRun to launch as host on Chrome

I web customErrors=off in web.config but still can't see the full error occuring on WindowsInstallerDownload under Chrome. I tried doing it local on the server, but still don't see the full error, only the friendly one.

Edited by user Friday, October 6, 2017 11:17:01 AM(UTC)  | Reason: Not specified

thanks 1 user thanked HDClown for this useful post.
mattjj on 10/5/2017(UTC)
mattjj  
#2 Posted : Thursday, October 5, 2017 3:18:54 PM(UTC)
mattjj


Rank: Newbie

Joined: 9/4/2014(UTC)
Posts: 2
United States
Location: NJ

Thanks: 8 times
Agreed - we are experiencing the same issues.
... >100 new .msi/.exe files with multiple security steps to launch the host session per day is crazy!
I don't think this is a problem with SC, but rather with Windows.
Either way, if anyone has a resolution I'd really appreciate it!
Scott  
#3 Posted : Friday, October 6, 2017 11:08:55 AM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
@HDClown Is the WindowsSelector installed on the Host computer? In Programs and Features, is there an entry for ScreenConnect Client (xxx)?

ClickOnceDirect is the NPAPI method that all browsers other than IE/Edge have deprecated.

As far as the customError, make sure the entry is placed into the correct section of the web.config. There are multiple system.web sections, but you want to ensure its in the one containing elements such as 'globalization' and 'compilation'.
ScreenConnect Team
HDClown  
#4 Posted : Friday, October 6, 2017 11:46:03 AM(UTC)
HDClown


Rank: Newbie

Joined: 3/25/2017(UTC)
Posts: 19
United States

Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: Scott Go to Quoted Post
@HDClown Is the WindowsSelector installed on the Host computer? In Programs and Features, is there an entry for ScreenConnect Client (xxx)?

ClickOnceDirect is the NPAPI method that all browsers other than IE/Edge have deprecated.

As far as the customError, make sure the entry is placed into the correct section of the web.config. There are multiple system.web sections, but you want to ensure its in the one containing elements such as 'globalization' and 'compilation'.


I got customError turned off, and here's what I get:

Code:

Server Error in '/' Application.

Could not find file 'C:\Program Files (x86)\ScreenConnect\Bin\ScreenConnect.ClientSetup.exe'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.IO.FileNotFoundException: Could not find file 'C:\Program Files (x86)\ScreenConnect\Bin\ScreenConnect.ClientSetup.exe'.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 


[FileNotFoundException: Could not find file 'C:\Program Files (x86)\ScreenConnect\Bin\ScreenConnect.ClientSetup.exe'.]
   System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +373
   System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) +1128
   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) +133
   ScreenConnect.WindowsExeInstallerBuilder.BuildFile(Stream stream, String binDirectoryPath, Byte[] publicKey, ClientLaunchParameters clientLaunchParameters) +125
   ScreenConnect.InstallerHandler.ProcessRequest(HttpContext context) +732
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +880
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +97


The file it's looking for does NOT exist. I have ScreenConnect.ClienSetup.msi but no .exe.

To be clear, the WindowsInstallerDownload error above occurs ONLY on Chrome. On IE11, Edge, and Firefox 56, nothing ever downloads for this option, it just sits there doing nothing, it doesn't throw any errors.

I'm not familiar with WindowsSelector so I went Googling and found this video but it was done for v5.6. I am on 6.3 and this server started as a clean install of 6.2 originally. I don't have WindowsSelector in my launch options. They are as follows:

ClickOnceDirect is only offered to IE11 and Edge, where it works fine. It's not offered for Chrome or Firefox.

Launch options by browser:

IE11 / Edge

IE11


Chrome 61 / Firefox 56

Chrome

Edited by user Friday, October 6, 2017 11:47:04 AM(UTC)  | Reason: Not specified

thanks 1 user thanked HDClown for this useful post.
mattjj on 10/7/2017(UTC)
Scott  
#5 Posted : Friday, October 6, 2017 12:26:16 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
What AV is installed on the ScreenConnect server? There isn't a reason why that ClientSetup file would be missing unless it had been moved/deleted by something.
ScreenConnect Team
HDClown  
#6 Posted : Friday, October 6, 2017 2:31:09 PM(UTC)
HDClown


Rank: Newbie

Joined: 3/25/2017(UTC)
Posts: 19
United States

Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: Scott Go to Quoted Post
What AV is installed on the ScreenConnect server? There isn't a reason why that ClientSetup file would be missing unless it had been moved/deleted by something.


Sophos EndPoint and Windows Defender that's native in Server 2016. Neither have quarantined any files or indicate any removal of items in the logging. I'm the only person who has worked on this particular server, so can't say why the file went missing.

I extracted the MSI I used for this 6.3 install and it has ScreenConncet.ClientSetup.exe in it, so it wasn't missing from the package. I did an in-place upgrade from 6.2 using this package.

I copied the file over to the server and I was able to get the ScreenConnect client onto my host machine as expected, and now UrlLaunch works properly.
mattjj  
#7 Posted : Saturday, October 7, 2017 4:39:03 AM(UTC)
mattjj


Rank: Newbie

Joined: 9/4/2014(UTC)
Posts: 2
United States
Location: NJ

Thanks: 8 times
Hi HDClown,

Thanks for the email. I thought I'd share as well:

Yes, I did do an in-place upgrade, but that was back in June and it was working fine until last week.

C:\Program Files (x86)\ScreenConnect\Bin\ScreenConnect.ClientSetup.exe is in place and has a date of 6/14/2017...

What I'm getting is ConnectWiseControl.Client(xxx).exe or the other connection types iterated many times, and have to keep running the newly downloaded file, and then telling Windows that it's ok to run it.

... You did trigger this tired mind into a different (and obvious) direction though that just resolved my issue.

On the popup screen where you have the option to choose the next connection option, there is a hyperlink that allows you to choose the best connection type.



I clicked on SystemProfiles and it gave me the following list:



In my case I went down the list and right-clicked to open in new tab until I realized that I needed to select WindowsDesktop[5.0-6.0]:Chrome:ClickOnce

On selecting this option, I was then presented with another screen where I was able to choose from the following menu:



In my case ClickOnceDirect was the correct choice.

I’m now able to get back into a session immediately, and it appears that reconnected sessions (reboots) are working properly now as well.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.