logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
JeremyB132  
#1 Posted : Thursday, February 8, 2018 4:52:18 PM(UTC)
JeremyB132


Rank: Guest

Joined: 2/8/2018(UTC)
Posts: 2

I am having issues with getting Screenconnect to work on 443 and 80 with a VPS server that has CPanel and Apache installed. The OS is CentOS 6. I am seeing the following in my logs:

Exception rethrown at [0]:

at (wrapper xdomain-invoke) ScreenConnect.WebServer:Startup ()
at ScreenConnect.AppDomainServiceBase.StartServiceInternal () [0x00000] in <filename unknown>:0
Event (2018/02/08 20:42:35.523 +04:00, ScreenConnect Session Manager, Information): Starting service...
Event (2018/02/08 20:42:36.217 +04:00, ScreenConnect Session Manager, Information): Successfully started service.
Event (2018/02/08 20:42:36.217 +04:00, ScreenConnect Relay, Information): Starting service...
Event (2018/02/08 20:42:36.544 +04:00, ScreenConnect Relay, Information): Successfully started service.
Event (2018/02/08 20:42:36.545 +04:00, ScreenConnect Web Server, Information): Starting service...
Event (2018/02/08 20:43:01.808 +04:00, ScreenConnect Web Server, Error): Failed to start service: System.Net.Sockets.SocketException: Address already in use

I have 4 IP's total. Two are nameservers and one is the shared IP for everything else. The 4th IP is specifically for ScreenConnect. I have updated the web.config with the new public IP address. But everytime I start it I get the following.

root@server[/opt/screenconnect]# netstat -tulpn | grep :80
tcp 0 0 209.217.250.82:8041 0.0.0.0:* LISTEN 7388/mono
tcp 0 0 127.0.0.1:8042 0.0.0.0:* LISTEN 7388/mono
tcp 0 0 209.217.250.76:80 0.0.0.0:* LISTEN 29455/httpd
tcp 0 0 209.217.250.78:80 0.0.0.0:* LISTEN 29455/httpd
tcp 0 0 209.217.250.77:80 0.0.0.0:* LISTEN 29455/httpd
tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN 29455/httpd



For testing I switched the Web Server over to port 80 and the relay to 8041. I set Apache to reserve the IP that I want to run screenconnect on. I also update DNS for help.domain.com which is what I used to run SC on to the new IP. I am at a loss here on what else to do. Any ideas?
Scott  
#2 Posted : Thursday, February 8, 2018 5:49:59 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,566
United States

Thanks: 3 times
Was thanked: 313 time(s) in 270 post(s)
Within the web.config found at /opt/screenconnect/web.config, what's the exact value for the 'WebServerListenUri' setting?
ScreenConnect Team
JeremyB132  
#3 Posted : Thursday, February 8, 2018 6:24:44 PM(UTC)
JeremyB132


Rank: Guest

Joined: 2/8/2018(UTC)
Posts: 2

Currently it is set at:

<add key="WebServerListenUri" value="http://help.thedigitalbyte.com:80/">
Scott  
#4 Posted : Friday, February 9, 2018 12:17:00 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,566
United States

Thanks: 3 times
Was thanked: 313 time(s) in 270 post(s)
As a test, try changing the help.thedigitalbyte.com to the IP address on which you want the web server to bind. Does that change the behavior?

Also is the machine behind a NAT?
ScreenConnect Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.