logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Scott  
#1 Posted : Tuesday, October 25, 2016 4:17:35 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,380
United States

Thanks: 3 times
Was thanked: 291 time(s) in 249 post(s)
Guest Initiated Chat

This extension allows a Guest to request a chat conversation before connecting to a Session. Guests can enter their name, email address, and an initial message which is all recorded within the session. Technicians can communicate directly from the Host page and send an invite through the conversation.

UserPostedImage

UserPostedImage

By right-clicking on the session, a Host can "Send Invite to Chat" to send a clickable link for the Guest to join the session.

UserPostedImage

UserPostedImage

Settings

ShouldShowEmailField - Governs whether or not the Guest is prompted to input their email address. Default value is false.

As with any Extension we are always open to feedback, feel free to leave yours below.
ScreenConnect Team
Camangery  
#2 Posted : Saturday, March 4, 2017 8:09:32 AM(UTC)
Camangery


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 10/18/2014(UTC)
Posts: 11
Man
United States

Was thanked: 2 time(s) in 1 post(s)
I get this error:

Object reference not set to an instance of an object.


Any idea why?
Scott  
#3 Posted : Monday, March 6, 2017 1:44:53 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,380
United States

Thanks: 3 times
Was thanked: 291 time(s) in 249 post(s)
Where do you see this error? Can you post a picture of a screenshot?
ScreenConnect Team
CalmComputing  
#4 Posted : Thursday, April 27, 2017 7:20:05 PM(UTC)
CalmComputing


Rank: Newbie

Joined: 3/5/2015(UTC)
Posts: 3
United States
Location: Massachusetts

Thanks: 2 times
Hi Scott,

I seem to have the same problem as the previous user. Here's a screenshot of the error message: http://pasteboard.co/9rrrx3Ukw.jpg

Any help is greatly appreciated.

Thank you.
Scott  
#5 Posted : Monday, May 1, 2017 12:40:39 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,380
United States

Thanks: 3 times
Was thanked: 291 time(s) in 249 post(s)
@CalmComputing What other extension(s) do you have installed?
ScreenConnect Team
SoCo_Systems  
#6 Posted : Wednesday, May 17, 2017 12:50:47 PM(UTC)
SoCo_Systems


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/29/2014(UTC)
Posts: 30
Man
United States
Location: Indianapolis, IN

Was thanked: 3 time(s) in 3 post(s)
I've done some experimenting with this, and the issue seems to be when "Guest Initiated Chat" is run in conjunction with "Auto Respond to Message".

With Guest Initiate Chat alone, it works as expected. The user fills out the box, clicks START, and the chat window opens. A new Invitation Only support session is created using the name they entered as the session name, a dot appears after the name (indicating a new message), and the message they sent is in the messages log. I receive an email with subject "Chat Client Message", body is "'sessionname' -Chat session created, notifying Technician..."

But if 'Auto Respond to Message' is enabled, upon clicking START, the "Object reference not set to an instance of an object" message appears, as was posted earlier. An invitation only support session is created, but the message is NOT contained there. I still receive the email.

On their own each extension is great, they just don't play nice together.

Suggestions for improvement: some sort of CAPTCHA, challenge question, or password prompt on the initial screen. Nothing fancy, just enough to prevent spam bots from flooding the server with new sessions. And I can't figure out what the prompt for email option does with the email address. I checked the first couple of sessionproperty.custom fields, but it wasn't there.
Scott  
#7 Posted : Monday, May 22, 2017 12:20:40 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,380
United States

Thanks: 3 times
Was thanked: 291 time(s) in 249 post(s)
@SoCo_Systems I put in a fix for the error you describe above when creating a chat session. The fix is to the Auto Respond to Message extension, version 1.3.9. Once it passes QA I will publish it so please keep an eye out; but it might be a few days.

As for the email address field, that value is placed in a Note attached to the session.

Quote:
Suggestions for improvement: some sort of CAPTCHA, challenge question, or password prompt on the initial screen. Nothing fancy, just enough to prevent spam bots from flooding the server with new sessions.


Are you having lots of sessions created and not sure of the source? Or are you wanting this as a preventative measure?
ScreenConnect Team
SoCo_Systems  
#8 Posted : Sunday, May 28, 2017 7:24:09 PM(UTC)
SoCo_Systems


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/29/2014(UTC)
Posts: 30
Man
United States
Location: Indianapolis, IN

Was thanked: 3 time(s) in 3 post(s)
Sorry for the delayed reply Scott, I've been on vacation.
I haven't had a single bogus/spamming session created, but I've only started testing 6.x with extensions on an isolated box. My production server is still running 5.6 with no extensions. The lack of captcha may not be an issue at all, it just seems like it could be.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.