logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
pfp  
#1 Posted : Wednesday, December 21, 2016 7:40:25 PM(UTC)
pfp


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 6/18/2015(UTC)
Posts: 44
United States

Thanks: 5 times
Was thanked: 1 time(s) in 1 post(s)
Internal users - Can no longer enter display name / full name (I forget what you label it) or two factor authentication info.
Ben B  
#2 Posted : Wednesday, December 21, 2016 7:59:19 PM(UTC)
Ben B


Rank: Administration

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 10/2/2015(UTC)
Posts: 208

Thanks: 1 times
Was thanked: 44 time(s) in 40 post(s)
Originally Posted by: pfp Go to Quoted Post
Internal users - Can no longer enter display name / full name (I forget what you label it) or two factor authentication info.


Good afternoon,

You can make the Display Name field visible on the Create User modal by setting the SecurityPanel.DisplayNameVisible web resource value to true.

Likewise, you can make the OTP (email, goog, yubi, linotp) field visible on the Create User modal by setting the SecurityPanel.PasswordQuestionVisible web resource value to true.

Both of these settings are configurable via the Web Resources table on the Admin page Appearance tab.
ScreenConnect Team
pfp  
#3 Posted : Wednesday, December 21, 2016 8:06:19 PM(UTC)
pfp


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 6/18/2015(UTC)
Posts: 44
United States

Thanks: 5 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: Ben B Go to Quoted Post
Originally Posted by: pfp Go to Quoted Post
Internal users - Can no longer enter display name / full name (I forget what you label it) or two factor authentication info.


Good afternoon,

You can make the Display Name field visible on the Create User modal by setting the SecurityPanel.DisplayNameVisible web resource value to true.

Likewise, you can make the OTP (email, goog, yubi, linotp) field visible on the Create User modal by setting the SecurityPanel.PasswordQuestionVisible web resource value to true.

Both of these settings are configurable via the Web Resources table on the Admin page Appearance tab.


Both were visible on most recent 6.0 build before I upgraded.

Sure enough SecurityPanel.DisplayNameVisible was false on 6.1 and setting it to true showed the field and all the values already entered for them.

SecurityPanel.PasswordQuestionVisible is already true but the 2FA field is not shown.
pfp  
#4 Posted : Wednesday, December 21, 2016 8:09:38 PM(UTC)
pfp


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 6/18/2015(UTC)
Posts: 44
United States

Thanks: 5 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: pfp Go to Quoted Post
SecurityPanel.PasswordQuestionVisible is already true but the 2FA field is not shown.


Interesting, the value was "True" which was working previously.
Now on 6.1 it wants "true"


Scott  
#5 Posted : Thursday, December 22, 2016 2:05:40 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,380
United States

Thanks: 3 times
Was thanked: 291 time(s) in 249 post(s)
Thanks for the report and digging a bit deeper. Using that information I've replicated the issue internally and registered it as a defect. We'll continue to investigate.
ScreenConnect Team
shaunrieman  
#6 Posted : Friday, February 17, 2017 2:07:28 AM(UTC)
shaunrieman


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 3/6/2013(UTC)
Posts: 45

Thanks: 1 times
Was thanked: 2 time(s) in 1 post(s)
Changed this setting and two factor options are still missing.
Scott  
#7 Posted : Monday, February 20, 2017 1:47:27 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,380
United States

Thanks: 3 times
Was thanked: 291 time(s) in 249 post(s)
@shaunrieman you changed SecurityPanel.PasswordQuestionVisible to "True" or "true" and nothing is showing within the User table in the Security tab?

What version of ScreenConnect are you using? Is it on a Windows or Linux server?
ScreenConnect Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.