logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
M_Albert  
#1 Posted : Sunday, February 5, 2017 5:11:27 AM(UTC)
M_Albert


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 6/20/2013(UTC)
Posts: 32
Location: Alaska

Thanks: 10 times
Was thanked: 1 time(s) in 1 post(s)
To login to my dashboard, I normally just go to http://MyServerName.com:1234/login, and that gets me straight to my login screen.

But lately I've been using published support sessions. I had some issues with my installation files that I mostly have resolved, however in order for my users to successfully get to the guest page, they have to type in http://MyServerName:1234/guest.aspx.

What is the normal, default behavior of the guest page, should I have to be adding the "guest", or "guest.aspx" to the address? I thought that just browsing to http://MyServerName:1234 should take users to that page.

Thanks for your assistance.
Michael L  
#2 Posted : Monday, February 6, 2017 2:05:21 PM(UTC)
Michael L


Rank: Administration

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/18/2015(UTC)
Posts: 54
Man
United States

Thanks: 4 times
Was thanked: 10 time(s) in 8 post(s)
Originally Posted by: M_Albert Go to Quoted Post
To login to my dashboard, I normally just go to http://MyServerName.com:1234/login, and that gets me straight to my login screen.

But lately I've been using published support sessions. I had some issues with my installation files that I mostly have resolved, however in order for my users to successfully get to the guest page, they have to type in http://MyServerName:1234/guest.aspx.

What is the normal, default behavior of the guest page, should I have to be adding the "guest", or "guest.aspx" to the address? I thought that just browsing to http://MyServerName:1234 should take users to that page.

Thanks for your assistance.


The default behavior is that you should just type in your URL to get to the guest page without having to type out "Guest.aspx" - see https://support.screenconnect.com for an example. I just looked back through your post history, and it sounds like what you're seeing might be leftover from that old customization you had for the landing page. Three things to check within the web.config file. Make sure you copy/paste the whole file to make a backup before changing anything:

1) Look at the following section and make sure this is set up as follows:
Code:
<urlMappings enabled="true">
<add url="~/Guest" mappedUrl="~/Guest.aspx" />


2) Look for the key called DefaultDocumentName. The value for that should be:
Code:
<add key="DefaultDocumentName" value="Guest.aspx" />


3) Take a look at the value for WebServerListenUri - that should just be:
Code:
<add key="WebServerListenUri" value="http://+:1234/" />




If you're wanting to get back to a fresh/default installation, you could do a "migration" using this wiki article as a guide to get onto a fresh installation.

1) (very important) Back up your installation by copying the entire installation directory and pasting it to another location
2) Uninstall SC from the server
3) Reinstall a fresh copy onto the server - make sure it's the same version as what was installed
4) Stop the 3 services
5) Copy over the following files from the backup into your fresh installation:
web.config file
\App_ClientConfig
\App_Data
\App_WebResources
6) Restart services

The migration might not be necessary but I noticed that you had that old customization out there in your post history, so figured that could be relevant. If any changes were made in the web.config file, doing the migration won't have any effect since you're just copying it over. The only thing that you actually NEED in the web.config file to ensure that you still have access to your machines is the Asymmetric key line.

Edited by user Monday, February 6, 2017 2:06:36 PM(UTC)  | Reason: Not specified

ConnectWise Control (ScreenConnect) Support Team
thanks 1 user thanked Michael L for this useful post.
M_Albert on 2/6/2017(UTC)
M_Albert  
#3 Posted : Monday, February 6, 2017 7:25:18 PM(UTC)
M_Albert


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 6/20/2013(UTC)
Posts: 32
Location: Alaska

Thanks: 10 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: Michael L Go to Quoted Post
Originally Posted by: M_Albert Go to Quoted Post
To login to my dashboard, I normally just go to http://MyServerName.com:1234/login, and that gets me straight to my login screen.

But lately I've been using published support sessions. I had some issues with my installation files that I mostly have resolved, however in order for my users to successfully get to the guest page, they have to type in http://MyServerName:1234/guest.aspx.

What is the normal, default behavior of the guest page, should I have to be adding the "guest", or "guest.aspx" to the address? I thought that just browsing to http://MyServerName:1234 should take users to that page.

Thanks for your assistance.


The default behavior is that you should just type in your URL to get to the guest page without having to type out "Guest.aspx" - see https://support.screenconnect.com for an example. I just looked back through your post history, and it sounds like what you're seeing might be leftover from that old customization you had for the landing page. Three things to check within the web.config file. Make sure you copy/paste the whole file to make a backup before changing anything:

1) Look at the following section and make sure this is set up as follows:
Code:
<urlMappings enabled="true">
<add url="~/Guest" mappedUrl="~/Guest.aspx" />


2) Look for the key called DefaultDocumentName. The value for that should be:
Code:
<add key="DefaultDocumentName" value="Guest.aspx" />


3) Take a look at the value for WebServerListenUri - that should just be:
Code:
<add key="WebServerListenUri" value="http://+:1234/" />




If you're wanting to get back to a fresh/default installation, you could do a "migration" using this wiki article as a guide to get onto a fresh installation.

1) (very important) Back up your installation by copying the entire installation directory and pasting it to another location
2) Uninstall SC from the server
3) Reinstall a fresh copy onto the server - make sure it's the same version as what was installed
4) Stop the 3 services
5) Copy over the following files from the backup into your fresh installation:
web.config file
\App_ClientConfig
\App_Data
\App_WebResources
6) Restart services

The migration might not be necessary but I noticed that you had that old customization out there in your post history, so figured that could be relevant. If any changes were made in the web.config file, doing the migration won't have any effect since you're just copying it over. The only thing that you actually NEED in the web.config file to ensure that you still have access to your machines is the Asymmetric key line.


Michael, thanks so much for this post, your first section of steps totally fixed my issue! From my post from a few months ago, you saw my issue. I went through and removed some files and folders but still had the issue.

Your steps 1 and 2 fixed my problem, where the entries had currently referred to "guest.html", and not ".aspx". Changing those values made it all work again.

I only regret that I have only 1 single "thanks" to give your post!

-Michael

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.