logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
sparkey  
#1 Posted : Tuesday, February 14, 2017 5:00:05 PM(UTC)
sparkey


Rank: Guest

Joined: 2/14/2017(UTC)
Posts: 1
Sweden

Hey guys,

Just started laborating the triggers and it seems to work fine over email but cant get the http triggers to work. Someone that can see what the problem is on this simple test trigger?

I have a php script running on the other side and it works when sending the exact same parameters through restclient.

Screenshot

Edit: I can see in the nginx access log that http sends a request but nothing when using https.

Edit2: When running netcat for test purposes i can see that when using https i only get something scrambled. When using http it works.

Code:
root@server01:/home/username/ScreenConnect_6.1.12292.6236_Install# while true; do netcat -l 443 -w 1; echo; echo; done;
EAX▒F▒k▒▒▒;;ɨݦ▒釥▒Z▒▒▒ƃ▒_ϯP)5/
        localhost

Edited by user Wednesday, February 15, 2017 12:20:26 PM(UTC)  | Reason: Not specified

Scott  
#2 Posted : Wednesday, February 22, 2017 1:59:41 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,566
United States

Thanks: 3 times
Was thanked: 313 time(s) in 270 post(s)
From your example, it looks like information is being received. To my knowledge, netcat doesn't support SSL and thus would display the encrypted information, this stackoverflow thread seems to agree, but it looks like you can try openssl.
ScreenConnect Team
netpro25  
#3 Posted : Friday, February 9, 2018 5:24:44 AM(UTC)
netpro25


Rank: Guest

Joined: 2/9/2018(UTC)
Posts: 3
United States

Hello,

I'm having a similar issue and I think it's related to certificate verification failing. There should be a way to disable certificate verification as it only works for a very limited number of certificates. For instance I setup a basic trigger to post to https://webhook.site for testing and it refuses to work unless to remove the 's' in https. Here is an article that discusses disabling the SSL certificate verification for C# HttpWebRequest which I believe SC/CWC is using. https://stackoverflow.com/questions/12506575/how-to-ignore-the-certificate-check-when-ssl

Is it possible to have an override for this, or to add Let's Encrypt to the list of trusted certificates, or get a list of Trusted Certificate Issuers?
netpro25  
#4 Posted : Friday, February 9, 2018 7:35:39 AM(UTC)
netpro25


Rank: Guest

Joined: 2/9/2018(UTC)
Posts: 3
United States

So it looks like this is an issue with Mono and Let's Encrypt. I may just have to switch to a different certificate authority. I'm seeing an issue identical as described here

https://bugzilla.xamarin.com/show_bug.cgi?id=46382

Edited by user Friday, February 9, 2018 7:40:20 AM(UTC)  | Reason: Not specified

netpro25  
#5 Posted : Friday, February 9, 2018 2:07:22 PM(UTC)
netpro25


Rank: Guest

Joined: 2/9/2018(UTC)
Posts: 3
United States

So in order to get this working I installed Nginx on my SC server, and used the following configuration to proxy http to https.

Code:
server {
    listen 127.0.0.1:88;
    server_name localhost;

    location / {
       # proxy to the original site
        proxy_pass https://api.myrestserver.com; <--- CHANGE THIS

        # prevents gzip compression, which cannot be processed by
        # HttpSubModule
        proxy_set_header Accept-Encoding '';
    }
}



I was then able to make a call to http://localhost:88/ which was proxied to my remote server via https.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.