logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
TaylorSystems  
#1 Posted : Tuesday, June 13, 2017 7:03:56 PM(UTC)
TaylorSystems


Rank: Guest

Joined: 5/3/2016(UTC)
Posts: 2
Man
United States
Location: California

Thanks: 1 times
I did a search for 'Thumbnail' entries and could not find anything that addresses this problem that recently showed up with the latest DEBUG releases.

I find the 'Screen Preview' very useful. There used to be a link or button that would allow the Thumbnail to be EXPANDED. This has disappeared when I installed the most recent 'DEBUG' builds.

Have I missed something here???

Is there a NEW Setting that I need to tweak to get the EXPAND Thumbnail capability back???


Thanks!!!

-Larry-

Jesseb  
#2 Posted : Thursday, June 15, 2017 4:20:47 PM(UTC)
Jesseb


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 3/9/2015(UTC)
Posts: 76
United States
Location: Texas

Thanks: 13 times
Was thanked: 20 time(s) in 6 post(s)
This is an extension, and seems to not work with the newest 6.3 beta just yet. Typically, extension compatibility is updated after the final stable release.
TaylorSystems  
#3 Posted : Thursday, June 15, 2017 7:42:39 PM(UTC)
TaylorSystems


Rank: Guest

Joined: 5/3/2016(UTC)
Posts: 2
Man
United States
Location: California

Thanks: 1 times
Thanks for the quick response and explanation. I thought the issue was something along those lines. I will keep checking for the Extension Updates after 6.3 is released.

Thanks Again!

Jesseb  
#4 Posted : Tuesday, June 20, 2017 4:01:29 PM(UTC)
Jesseb


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 3/9/2015(UTC)
Posts: 76
United States
Location: Texas

Thanks: 13 times
Was thanked: 20 time(s) in 6 post(s)
So if you host your own instance, looks like you can fix this yourself until they update the extension. Resolution is pretty bad, but haven't played with it yet. I assume you can use the Developers extension as well, but I did this directly on my server.

Use at your own risk!

- Go to c:\program files (X86)\screenconnect\app_extensions
- Find the UUID folder of the Expand Thumbnail extension (just click through each one till you find the "Promote.png" that's the same icon as in the Extensions page)
- Backup "Initializer.js" and "OldInintializer.js" (not sure if you need to edit both, but I did just in case)
- Open each of those .js files in your text editor, find the phrases "isGeneralTab" and "case 'General':"
- Replace them with "isStartTab" and "case 'Start':", respectively.
- Save, and restart your screenconnect services

Before
before

After
after
Scott  
#5 Posted : Monday, June 26, 2017 11:33:28 AM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
Thanks for taking a look @Jesseb, I usually wait until a new version of ScreenConnect is closer to stable release before updating any extensions. While this is not a guarantee, it's likely 6.3 will be stable within the next few days/a week or so.

With that in mind, version 1.2.2 of the Expand Thumbnail Preview extension is now live with a fix to display the command within the correct tab on the Host page.

Also, @Jesseb, you mention that the image itself is pretty blurry. The quality of the image is controlled by the web.config settings 'GuestScreenshotMaxScalePercent' and 'GuestScreenshotMaxPixelCount'. They default to 20 and 30000 respectively. Increasing them to 80 and 3000000 provides a significantly clearer picture. Feel free to tweak with those numbers also, just keep in mind that every save to the web.config file restarts the server's services.
ScreenConnect Team
Jesseb  
#6 Posted : Monday, June 26, 2017 12:24:53 PM(UTC)
Jesseb


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 3/9/2015(UTC)
Posts: 76
United States
Location: Texas

Thanks: 13 times
Was thanked: 20 time(s) in 6 post(s)
Thanks Scott! Resolution was much better after I adjusted the quality. I forgot I had reset those settings back to default after installing 6.3. Sorry I should have updated the thread =)
Jesseb  
#7 Posted : Friday, June 30, 2017 8:40:16 PM(UTC)
Jesseb


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 3/9/2015(UTC)
Posts: 76
United States
Location: Texas

Thanks: 13 times
Was thanked: 20 time(s) in 6 post(s)
Originally Posted by: Scott Go to Quoted Post

With that in mind, version 1.2.2 of the Expand Thumbnail Preview extension is now live with a fix to display the command within the correct tab on the Host page.


Scott, is this confirmed to work with latest stable release? Does not seem to be working for me. I made sure to revert my custom changes to the .js files prior to updating to version 1.2.2
Jesseb  
#8 Posted : Friday, July 7, 2017 4:13:38 PM(UTC)
Jesseb


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 3/9/2015(UTC)
Posts: 76
United States
Location: Texas

Thanks: 13 times
Was thanked: 20 time(s) in 6 post(s)
Originally Posted by: Jesseb Go to Quoted Post
Originally Posted by: Scott Go to Quoted Post

With that in mind, version 1.2.2 of the Expand Thumbnail Preview extension is now live with a fix to display the command within the correct tab on the Host page.


Scott, is this confirmed to work with latest stable release? Does not seem to be working for me. I made sure to revert my custom changes to the .js files prior to updating to version 1.2.2


After uninstalling the extension, checked the App_Extension folder and made sure it was completely removed and reinstalling fresh, still doesn't work.

Also tried toying with the manifest and .js files to no avail.

**EDIT**
I noticed in Notepad++ the main 'Initializer.js' file is 'Windows CR LF' encoded, while the two older .js files are 'Unix LF'. I tried copying 'Early6xInitializer.js' and renaming to just 'Initializer', and replaced General with Start as mentioned previously, but that did not work either.

Edited by user Friday, July 7, 2017 4:19:10 PM(UTC)  | Reason: Not specified

jasgot  
#9 Posted : Friday, July 14, 2017 2:45:23 AM(UTC)
jasgot


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 11/11/2010(UTC)
Posts: 65
Location: Detroit, MI

Thanks: 3 times
Was thanked: 5 time(s) in 4 post(s)
I am running 6.3 and it is working as it always has.

My issue is that if I use the Settings to disable it - uncheck "ViewSessionGuestScreenshot" the text "Expand Thumbnail Preview" still shows up when using the Expand Thumbnail Extension. This text should go away when "ViewSessionGuestScreenshot" is set to disable.



Originally Posted by: TaylorSystems Go to Quoted Post
I did a search for 'Thumbnail' entries and could not find anything that addresses this problem that recently showed up with the latest DEBUG releases.

I find the 'Screen Preview' very useful. There used to be a link or button that would allow the Thumbnail to be EXPANDED. This has disappeared when I installed the most recent 'DEBUG' builds.

Have I missed something here???

Is there a NEW Setting that I need to tweak to get the EXPAND Thumbnail capability back???


Thanks!!!

-Larry-



Jesseb  
#10 Posted : Friday, July 14, 2017 2:47:35 AM(UTC)
Jesseb


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 3/9/2015(UTC)
Posts: 76
United States
Location: Texas

Thanks: 13 times
Was thanked: 20 time(s) in 6 post(s)
I should have updated: There seems to be a compatibility issue with the new Tiled Session View extension. Soon as I uninstalled that one, functionality came back.
thanks 1 user thanked Jesseb for this useful post.
promptcare on 7/28/2017(UTC)
Scott  
#11 Posted : Monday, July 17, 2017 11:31:33 AM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,518
United States

Thanks: 3 times
Was thanked: 305 time(s) in 262 post(s)
@Jesseb Once again thanks for letting me know! I'll register something about the interaction and while it might not be immediately, I'll take a look when I can.

Thanks!
ScreenConnect Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.