logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
jabouley  
#1 Posted : Tuesday, July 18, 2017 12:54:10 PM(UTC)
jabouley


Rank: Member

Joined: 6/10/2013(UTC)
Posts: 18

Just want to confirm that ScreenConnect will no longer support Windows Server 2003 as the product now requires .NET 4.5.
Your "requirements" page seems to indicate that 4.5 will install on 2003, but that does not seem to be the case.
https://docs.connectwise...rver_system_requirements

Thanks,
J
Michael L  
#2 Posted : Tuesday, July 25, 2017 3:50:07 PM(UTC)
Michael L


Rank: Administration

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/18/2015(UTC)
Posts: 65
Man
United States

Thanks: 6 times
Was thanked: 11 time(s) in 9 post(s)
You'll still be able to install/use the client software to connect to those machines, but you're correct in that Server 2003 doesn't support .NET 4.5, so the server software for 6.3 won't work:

https://docs.microsoft.c...rted/system-requirements

Windows Server 2003 is based on the XP platform, so the latest version of .NET you can install is 4.0. Therefore, the latest version of Control/ScreenConnect that you'll be able to use on that server is 6.2 (the .NET 4.5 requirement is new for 6.3).

We added a disclaimer at the top of the requirements page indicating that we may not be able to guarantee performance for all end of life operating systems - Server 2003 support ended back in July, 2015, and Microsoft didn't offer any extended support for it beyond that date, but earlier versions of the server do still work with that OS.
ConnectWise Control (ScreenConnect) Support Team
jabouley  
#3 Posted : Tuesday, July 25, 2017 6:23:34 PM(UTC)
jabouley


Rank: Member

Joined: 6/10/2013(UTC)
Posts: 18

Hi Michael,

Thanks for the confirmation. I went back and reread the requirements and I do agree that it says it now requires .net 4.5 and you cannot guarantee performance on end of life systems. However Server 2003 is still listed under the supported platforms and as the title of the page states "Server System Requirements", implies that it works on Server 2003, as a "Server".

In my opinion that page could use some clarification as I can bet I won't be the last to question this.

Thanks,
J
Michael L  
#4 Posted : Tuesday, July 25, 2017 7:22:25 PM(UTC)
Michael L


Rank: Administration

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/18/2015(UTC)
Posts: 65
Man
United States

Thanks: 6 times
Was thanked: 11 time(s) in 9 post(s)
I can see your point, definitely! :)

I'll get this feedback passed to our documentation team to review.
ConnectWise Control (ScreenConnect) Support Team
spen70  
#5 Posted : Friday, July 28, 2017 12:04:53 PM(UTC)
spen70


Rank: Guest

Joined: 7/28/2017(UTC)
Posts: 1
United Kingdom

Hi Jabouley

Are you able to confirm which features of the .NET 4.5 framework ScreenConnect server 6.3 and above now require? Is it possible to modify the app.config to still target earlier versions of the framework and / or run under mono for Windows instead for these end of life systems?

Thanks
Ian.
jabouley  
#6 Posted : Friday, July 28, 2017 4:45:46 PM(UTC)
jabouley


Rank: Member

Joined: 6/10/2013(UTC)
Posts: 18

Hi Ian,

I have no idea, all I know is I am unable to install on 2003 as it checks for the .Net framework requirement. I will probably, just install W10 or 2012 and move ScreenConnect over.

Thanks,
J
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.