logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages12>
Options
Go to last post Go to first unread
LaSepp  
#1 Posted : Tuesday, June 4, 2013 5:23:03 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
As I am continuing to integrate ScreenConnect into our own Support and Customer Management Software I have started writing a small C# library that does the interaction with ScreenConnect.

To demonstrate what this library can do I've included a demo program that gives you access to your ScreenConnect Sessions with just one click from the Windows System Tray (see Screenshot below).


ScreenConnectIntegration

This Library helps to integrate ScreenConnect into your .NET Projects
All interaction is done via the on-board mechanisms - no need to change anything on the server-side!

Sample Program ScTray included - shows how to use the library as ScrennConnect GUI for the Systray.

Features:
* List Session Categories
* List Sessions in Category
* Join Host Session
* Create new Session

Limitations:
* At the moment only works with Active Directory Authentication
* Only tested with v3

ToDo:
* Add Support for Forms Authentication
* Add Client Capabilities (List and Join as Guest)
* Add Support for creating Meetings
* Add Support for Downloading Installers
* Add Support for Uninstall/Reinstall
* Add Support for reading/writing Notes

Requirements:
* Windows OS
* .NET Framework 2.0

Download:
* Download Page
* Direct Download (contains Source + Demo Program ScTray)

UserPostedImage
thanks 9 users thanked LaSepp for this useful post.
dnomade on 11/22/2013(UTC), ckibodeaux on 12/30/2013(UTC), solutionssquad on 1/13/2014(UTC), teksigns on 1/14/2014(UTC), ditkar on 8/4/2014(UTC), sllewji on 9/25/2014(UTC), ddre on 11/28/2015(UTC), oangaza on 10/31/2016(UTC), FilthX on 1/6/2017(UTC)
OnSite  
#2 Posted : Thursday, June 13, 2013 12:38:31 PM(UTC)
OnSite


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 11/3/2011(UTC)
Posts: 61
Location: Windsor

Thanks: 1 times
Was thanked: 5 time(s) in 5 post(s)
Why nobody's thanked you yet I don't know. This is very cool. I'm not doing development so really, SCTray is the useful bit to me, but it's really cool. Thanks for not requiring .NET 6.0 and IE 17 and Java 1.9 My primary work machine is a Server 2003 box and while it's due for replacement it does the job and it's nice to see simple software still run on it.
LaSepp  
#3 Posted : Friday, June 14, 2013 6:59:17 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
I'm glad you can get use out of it.

I like keeping the .NET Version level at the minimum as with most machines it just works out of the box (I can install my tools on nearly any client PC/Server without having to worry much about first upgrading .NET)
Jake  
#4 Posted : Saturday, June 15, 2013 4:47:49 PM(UTC)
Jake


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
I finally had a chance to look at this today. Nice!

And you may be able to support forms auth much easier than you thought. Forms auth credentials can be sent over HTTP basic authentication. It may work as is, or you may just be able to set a property like this:
http://msdn.microsoft.co...est.preauthenticate.aspx

.. as I'm not sure we send a 401 response otherwise.
ScreenConnect Team
tmgordon  
#5 Posted : Thursday, August 8, 2013 1:20:50 PM(UTC)
tmgordon


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 3/13/2013(UTC)
Posts: 32
Location: Omaha, NE

Was thanked: 2 time(s) in 1 post(s)
How to you pass your ScreenConnect URL to the ScTray demo?
LaSepp  
#6 Posted : Saturday, August 10, 2013 5:50:26 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi tmgordon,

just create a Shortcut to the ScTray.exe and append the URL as parameter.
mynameisjona  
#7 Posted : Monday, September 23, 2013 8:49:10 PM(UTC)
mynameisjona


Rank: Member

Joined: 9/23/2013(UTC)
Posts: 15
Location: Los ANgeles

Thanks: 1 times
Can you give the exact details on where to append the parameter? I have been trying and I get a INVALID URI. I have already added to local INTRANET. Thanks
LaSepp  
#8 Posted : Tuesday, September 24, 2013 2:03:50 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
In my Setup I create a new Shortcut to:
"C:\Program Files\ScTray\ScTray.exe" http://fw.csa-it.de:8040
mynameisjona  
#9 Posted : Tuesday, September 24, 2013 2:16:11 PM(UTC)
mynameisjona


Rank: Member

Joined: 9/23/2013(UTC)
Posts: 15
Location: Los ANgeles

Thanks: 1 times
That works. Too bad our server went down and I cant work on it. OIY!!!
Xrcougar  
#10 Posted : Wednesday, October 9, 2013 2:08:34 AM(UTC)
Xrcougar


Rank: Newbie

Joined: 10/9/2013(UTC)
Posts: 2

We have been using your excellent util but since the upgrade to the latest version of ScreeConnect it has stopped allowing us to login. Do you have any suggestions or will there be an update to the util?
LaSepp  
#11 Posted : Wednesday, October 9, 2013 4:40:39 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
I've just checked and can confirm that it seems to no longer work against v4.

I'm on vacation at the moment, but I will look into it.
Maybe it's just a minor thing to adjust.
LaSepp  
#12 Posted : Wednesday, October 9, 2013 5:34:01 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
As I am terrible with letting a challenge unsolved I just looked into it and did some tweaking and version detecting...

v4 does want some additional parameters that didn't exist in v3, so calls to the server failed.
The library now detects the Server version and sends the additional parameters if it's connecting to a v4 Server.

Please try the new version, I hope it will also work for you.
Xrcougar  
#13 Posted : Thursday, October 10, 2013 2:09:39 AM(UTC)
Xrcougar


Rank: Newbie

Joined: 10/9/2013(UTC)
Posts: 2

Your awesome, it works like a charm.
Thanks for looking into it even though you were on vacation.
reach2rv  
#14 Posted : Thursday, November 14, 2013 3:17:39 AM(UTC)
reach2rv


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 11/14/2013(UTC)
Posts: 48

Thanks: 11 times
Was thanked: 12 time(s) in 5 post(s)
Hi,

Thank you for this great app. it solves the problem of login in web and doing further things. System tray app works perfect. just wanted to know hoe to get the GUI as shown in screenshot.
LaSepp  
#15 Posted : Saturday, November 16, 2013 7:23:00 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi reach2rv,

The GUI you see in the background is another small .EXE file I made for my collegues and customers.
See this Post here for download and description.

It basically is just a browser window running in a separate application to have simple one click access to the SC Site without all the overhead of a full browser.
rjkreider  
#16 Posted : Thursday, December 26, 2013 2:28:00 PM(UTC)
rjkreider


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 4/24/2010(UTC)
Posts: 33
Man
United States

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
Hi LaSepp,

I am having trouble authenticating against version 4.1. Before I start digging around, have you had a chance to confirm it works ok in 4.1? If not, I'll probably fire up VS and tinker. I'm able to confirm that authentication is working properly on SC itself through the login page.

Thanks for your work on this, looks promising!

Regards,

Rich
LaSepp  
#17 Posted : Monday, January 6, 2014 1:00:37 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi rjkreider,

I just tried it against my SC 4.1.5817.5099 and it works just fine.

Do you use AD authentication or local authentication?

As both of the SC installations I can use for development are AD authentication I was not able to see if and how local authentication does work...
thanks 1 user thanked LaSepp for this useful post.
rjkreider on 1/6/2014(UTC)
rjkreider  
#18 Posted : Monday, January 6, 2014 2:45:05 PM(UTC)
rjkreider


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 4/24/2010(UTC)
Posts: 33
Man
United States

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
Hi LaSepp, I feel like a bonehead. The URL shortcut I was using included "/Host" at the end. After removing that, it works just fine. =)
rjkreider  
#19 Posted : Monday, January 6, 2014 10:00:17 PM(UTC)
rjkreider


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 4/24/2010(UTC)
Posts: 33
Man
United States

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
I enjoy this tool and I'm going to extend it to include thumbnail previews of desktops and some additional information (active/idle time) when hovering over unattended sessions in the menu. I'll report back progress on this.
LaSepp  
#20 Posted : Thursday, January 9, 2014 12:51:16 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
That sounds great!

If you could send me your changes when you're finished I will update the library so everyone can benefit.
solutionssquad  
#21 Posted : Monday, January 13, 2014 11:38:13 PM(UTC)
solutionssquad


Rank: Member

Joined: 1/13/2014(UTC)
Posts: 29

Thanks: 2 times
LOVE this utility (it was the last nail in LMI's coffin.
I have 1 issue though, it doesn't work with Google Auth multifactor.
Any way to get it working? How can I help?

Thanks!
LaSepp  
#22 Posted : Friday, January 24, 2014 12:26:07 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi solutionssquad,

At the moment I don't have Google Auth activated for my ScreenConnect.
I would need to analyze how SC does the prompts.

solutionssquad  
#23 Posted : Wednesday, January 29, 2014 3:51:54 PM(UTC)
solutionssquad


Rank: Member

Joined: 1/13/2014(UTC)
Posts: 29

Thanks: 2 times
Originally Posted by: LaSepp Go to Quoted Post
Hi solutionssquad,

At the moment I don't have Google Auth activated for my ScreenConnect.
I would need to analyze how SC does the prompts.



Great!

Same would apply to Email authentication.

Thanks again for your hard work.
LaSepp  
#24 Posted : Tuesday, April 29, 2014 12:44:37 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hello to everyone using the library,

With ScreenConnect v4.3 the way presence information are sent to the interface has changed.
I've updated the library to be able to understand the new format.

You will get errors when using the old version against SC 4.3
LaSepp  
#25 Posted : Wednesday, May 21, 2014 1:37:58 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Small Feature Update:

There are two new functions in SCHostInterface to download Access Session Installers: createAccessSessionMSI and createAccessSessionPKG
solutionssquad  
#26 Posted : Wednesday, May 21, 2014 5:55:43 PM(UTC)
solutionssquad


Rank: Member

Joined: 1/13/2014(UTC)
Posts: 29

Thanks: 2 times
Oddd... when I use the new version, it runs and shows the menus.
But, when I create a new session, or connect to an existing, it shows the download dialogue and then nothing happens.
LaSepp  
#27 Posted : Thursday, May 22, 2014 10:09:18 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi solutionssquad,

I've just unpacked and tried it on my test PC - seems to be working.
What version of Windows do you use? What type of authentication is in use in SC and what's your SC version?

Have you tried it on a different machine?
solutionssquad  
#28 Posted : Thursday, May 22, 2014 12:46:22 PM(UTC)
solutionssquad


Rank: Member

Joined: 1/13/2014(UTC)
Posts: 29

Thanks: 2 times
Using 7 Pro.
Standard user/password.
I hadn't till you suggested it, and same.
It downloads the program, and then nothing happens.
LaSepp  
#29 Posted : Thursday, May 22, 2014 2:31:07 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi,

that's strange.

I've just tried with and without AD Authentication, from two PCs with Windows 7 Pro against 3 different SC instances - I cannot reproduce the issue.
Do you have any Proxy Server configuration that might interfere?

Edited by user Thursday, May 22, 2014 2:31:40 PM(UTC)  | Reason: Not specified

solutionssquad  
#30 Posted : Thursday, May 22, 2014 2:35:05 PM(UTC)
solutionssquad


Rank: Member

Joined: 1/13/2014(UTC)
Posts: 29

Thanks: 2 times
smells like an SC issue.
We had a corrupted config file while back (knocked out 180 agents) and it acted this way.
I have ran the command to clear the cache, but I'm wondering if there is something somewhere else. :(
Alexander  
#31 Posted : Thursday, May 29, 2014 3:35:25 PM(UTC)
Alexander


Rank: Administration

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 7/23/2013(UTC)
Posts: 712
Man
Location: Raleigh, NC

Was thanked: 66 time(s) in 63 post(s)
Hmm, the same thing's happening for me, on Windows 8 Enterprise and SC version 4.4.6780.5255 with internal auth. I also noticed that the url being passed to LaunchApplication was missing the host, port, and encryption key.
Edit: Also, this url had Elsinore.ScreenConnect.WindowsClient.application, whereas one from SC had Elsinore.ScreenConnect.Client.application.

Edited by user Thursday, May 29, 2014 3:37:18 PM(UTC)  | Reason: Not specified

ScreenConnect Team
dhamofficial  
#32 Posted : Thursday, July 3, 2014 12:43:48 PM(UTC)
dhamofficial


Rank: Newbie

Joined: 7/3/2014(UTC)
Posts: 5
India
Location: bangalore

Thanks: 2 times
Hi LaSepp
Thanks for your nice tool, really appreciated your work.
I am trying to integrate Screenconnect into my ticketing tool (asp.net + C#), once new session is generated i am supposed to open the windows client for the executive and send a request mail to the end user.
When i try to open window client, the app is crashing due to insufficient parameters like hostname, relayport, hashkey...

Please advice on how to get the parameters from the hosted url with a small example

Thanks in advance.
LaSepp  
#33 Posted : Wednesday, July 9, 2014 4:03:48 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi dhamofficial,

the SCHostSession has a connect() Method. With that Method you can launch the Client directly.
But as I understand your question this is no option for you.
So I've just added a getLaunchURL() Method, that you can use to get the URL to for example put a link onto a page.

Hope this helps with your case.
thanks 1 user thanked LaSepp for this useful post.
dhamofficial on 7/10/2014(UTC)
LaSepp  
#34 Posted : Wednesday, August 20, 2014 11:56:30 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi everyone!

As ScreenConnect 5 is just around the corner I've taken the time to look into the SC5 compatibility.
This time the SC folks did big changes to their API (as in: Renamed just about every field name).

The new version now supports SC5 while still being compatible to every older version that was supported before.

Please note:
SC5 Support is still experimental - while I did test all features in the example program and my own software there might still be something not working in other constellations. As always, if you happen to come upon something not working, just post here and I will try to look into it.
thanks 1 user thanked LaSepp for this useful post.
sllewji on 9/25/2014(UTC)
rockgeneral  
#35 Posted : Tuesday, September 16, 2014 8:59:09 PM(UTC)
rockgeneral


Rank: Newbie

Joined: 1/29/2014(UTC)
Posts: 1
United States
Location: South Florida

Thank you for the great tool!

I noticed that it doesn't have the ability to transfer sessions. Do you have a code snippet that may point me in the right direction to add transfer functionality to the project?
leiby  
#36 Posted : Wednesday, October 22, 2014 1:38:02 AM(UTC)
leiby


Rank: Member

Joined: 8/21/2013(UTC)
Posts: 13
Location: usa

Just to make sure, I need to have SC installed on a windows server to use this tool, Am I correct?
Jake  
#37 Posted : Wednesday, October 22, 2014 1:49:17 AM(UTC)
Jake


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
Lasepp, you should look into packaging it as an extension to insulate yourself from future changes. And it'll make installation and configuration easier. Look at our screenconnector extension for reference.
ScreenConnect Team
LaSepp  
#38 Posted : Thursday, October 23, 2014 3:10:36 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi leiby,

I've never tried it with a SC Server running on Linux or MacOS, but I don't do anything OS related so should work just as it does on Windows.

Jake, I will look into SC extensions.
What I did like was that it did work out of the box without having to install / change anything server side.
If i understand correctly the extension has to be installed on the server?
leiby  
#39 Posted : Thursday, October 23, 2014 4:27:26 PM(UTC)
leiby


Rank: Member

Joined: 8/21/2013(UTC)
Posts: 13
Location: usa

Thanks LaSepp for the reply.

Does it work on windows 7?
Cause to use the Active Directory option I need to have it installed on a windows server as it says here

or maybe I do something wrong, i'm getting this error
UserPostedImage

Edited by user Friday, October 24, 2014 7:35:56 AM(UTC)  | Reason: Not specified

rjkreider  
#40 Posted : Wednesday, November 26, 2014 6:57:14 PM(UTC)
rjkreider


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 4/24/2010(UTC)
Posts: 33
Man
United States

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
Hi LaSepp

This didn't work on my system with server version 5 (stable).

I looked at code as I got the same error as leiby.

I hacked it and put this result:

Code:
if (serverVersion.StartsWith("ScreenConnect/5"))
            {
                // SC 5 Script Parser Hack
                String script = HttpPost(baseUrl + "/Script.ashx", "");
                String[] script_lines = script.Split('\r', '\n');
                
                
                var needle = Array.FindAll(script_lines, a => a.Contains("clp"));
                // Results in something like:
                // "}},\"context\":{\"clp\":{\"h\":\"support. [truncated]

                // String script_stripped = script_lines[0].Remove(0, 5);                
                String script_stripped = needle[0].Remove(0, 5);


                script_stripped = script_stripped.Remove(script_stripped.Length - 1);
                String clp = script_stripped.Remove(0, script_stripped.IndexOf("clp") + 5);


Either way, it's working for me now. Maybe you can have a look at the way it parses the version 5 stuff?

-Rich
thanks 1 user thanked rjkreider for this useful post.
LaSepp on 4/2/2015(UTC)
DougA2Z  
#41 Posted : Thursday, March 12, 2015 7:49:31 PM(UTC)
DougA2Z


Rank: Newbie

Joined: 3/12/2015(UTC)
Posts: 5
United States
Location: Arizona

Ive downloaded this and was trying to see if it worked on 5.1 stable, but i get the same error as the last two guys'
and it seems the author already added the SC5 hack in to the source code, so im still getting a NET framework error.
If anybody knows a fix, i would appreciate it as i have migrated our company from LMI to SC

DougA2Z  
#42 Posted : Thursday, March 12, 2015 10:20:30 PM(UTC)
DougA2Z


Rank: Newbie

Joined: 3/12/2015(UTC)
Posts: 5
United States
Location: Arizona

I havent been able to test it yet but i believe it was not working because i still had security on Internal and this only supports
Windows Active Directory
LaSepp  
#43 Posted : Thursday, April 2, 2015 11:46:50 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi everyone,

sorry that it took so long for a fix.

I used a similar solution to the one rjkreider came up with (fixed first then looked into the forum).

Seems to work in my integration scenario - please inform me if something is still broken.

I know, it's really hacky to get the CLPs like that.
As of the moment I haven't seen any other place to get the encryption key.
My thought of fixing it nicely by integrating a JavaScript engine would just introduce another dependency - and parsing with the JSON library didn't really work out as there are function calls inside the first assignment.

I also thought about writing a two-component integration.
But I do like it much better when the integration does not require any modification to the SC server.

So I guess there will always be some adjusting to newer SC versions every time they change their scripts.
MannyTC  
#44 Posted : Thursday, April 2, 2015 3:15:49 PM(UTC)
MannyTC


Rank: Advanced Member

Medals: Bug Buster Level One: Spoon!Level 3: Shirt off your back! Received 25 Thanks!

Joined: 2/19/2015(UTC)
Posts: 250
United States
Location: AZ

Thanks: 7 times
Was thanked: 48 time(s) in 41 post(s)
LaSepp, I cannot visit your website as Symantec blocks it due to reported driveby downloads threats being on it.

Also was wondering if SC integrated security would be supported at some point.
LaSepp  
#45 Posted : Monday, April 6, 2015 7:17:28 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
Hi,

Does it say what blacklist the site is on?
I couldn't find anything wrong with the site itself.

As for integrated security:
A customer of ours has a quite old version of SC running with integrated security. The SCTray Utility does work with their installation - so i guess it's worth a try.

Edited by user Monday, April 6, 2015 7:19:19 PM(UTC)  | Reason: typo

MannyTC  
#46 Posted : Monday, April 6, 2015 11:50:41 PM(UTC)
MannyTC


Rank: Advanced Member

Medals: Bug Buster Level One: Spoon!Level 3: Shirt off your back! Received 25 Thanks!

Joined: 2/19/2015(UTC)
Posts: 250
United States
Location: AZ

Thanks: 7 times
Was thanked: 48 time(s) in 41 post(s)
Originally Posted by: LaSepp Go to Quoted Post
Hi,

Does it say what blacklist the site is on?
I couldn't find anything wrong with the site itself.


Here is the report page on the site. Not sure if it is helpful or not.

Edited by user Monday, April 6, 2015 11:56:33 PM(UTC)  | Reason: Not specified

marktoo  
#47 Posted : Saturday, April 18, 2015 8:08:36 PM(UTC)
marktoo


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 3/29/2015(UTC)
Posts: 99
United States
Location: Metro DC

Thanks: 27 times
Was thanked: 8 time(s) in 7 post(s)
I am also blocked by Symantec's "Norton Safe Web". Same report page as presented by MannyTC. However, VirusTotal's URL Scanner shows this site as clean.

Perhaps appealing the "Drive-By Downloads" classification to Symantec would clear the site from this list...
jhardwick  
#48 Posted : Monday, November 23, 2015 6:23:32 PM(UTC)
jhardwick


Rank: Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 11/23/2015(UTC)
Posts: 16
United States

Thanks: 1 times
Was thanked: 2 time(s) in 2 post(s)
Any update on integrated authentication or has anyone had any luck getting it to work? I'm looking at SC cloud to replace LMI and I appear to be stuck. :(
PIN  
#49 Posted : Friday, November 27, 2015 11:01:43 AM(UTC)
PIN


Rank: Member

Joined: 9/11/2015(UTC)
Posts: 9
Czech Republic
Location: Prague

Thanks: 5 times
Looks awesome. I really wish something like that would come from official source.
LaSepp  
#50 Posted : Tuesday, December 15, 2015 6:22:57 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 53
Man
Germany

Thanks: 2 times
Was thanked: 17 time(s) in 9 post(s)
I just updated the Library to be able to connect to SC 5.4 in our Production environment.
Users browsing this topic
2 Pages12>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.